Python 版本升级3.5


Python 版本升级3.5

查看版本

python -V

下载新版本

wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz

解压

tar -zxvf Python-3.5.2.tgz

进入

cd Python-3.5.2/
./configure 

执行 ./configure 时,如果报错:
configure: error: no acceptable C compiler found in $PATH
说明没有安装合适的编译器。这时,需要安装/升级 gcc 及其它依赖包。

yum install make gcc gcc-c++ 

完成之后,重新执行:

./configure

编译 & 安装
配置完成之后,就可以编译了:

make 

安装:

make install

验证

python -V

Python 2.7.5

python3 -V

Python 3.5.2

注意:**在 /usr/local/bin/下有一个 python3 的链接,指向 bin 目录下的 python 3.5。
设置 3.x 为默认版本
查看 Python 的路径,在 /usr/bin 下面。可以看到 python 链接的是 python 2.7,所以,执行 python 就相当于执行 python 2.7。
将原来 python 的软链接重命名:

mv /usr/bin/python /usr/bin/python.bak

将 python 链接至 python3:

ln -s /usr/local/bin/python3 /usr/bin/python

这时,再查看 Python 的版本:

python -V

Python 3.5.2
配置 yum

升级 Python 之后,由于将默认的 python 指向了 python3,yum 不能正常使用,需要编辑 yum 的配置文件:

vi /usr/bin/yum

同时修改:

vi /usr/libexec/urlgrabber-ext-down

将两个文件中的 #!/usr/bin/python 改为 #!/usr/bin/python2.7,保存退出即可。


文章作者: 时间旅行者
文章链接: https://www.334420.club
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 时间旅行者 !
评论
 上一篇
Sublime-Text3安装Package Control插件 Sublime-Text3安装Package Control插件
安装 一.使用以下方法之一来安装程序包控制: 命令面板 1.打开命令面板:Win/Linux: ctrl+shift+p, Mac: cmd+shift+p 2.输入Install Package Control 按回车键 二.
下一篇 
中文CloudFlare-ddns 中文CloudFlare-ddns
下载配置文件wget https:/www.googlecn.cc/Code/cf-ddns.confwget https:/www.googlecn.cc/Code/cf-ddns.py 下载:Github